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Error with Social Security Number display (LMR-2004)

Error with Social Security Number display (LMR-2004)

Issue Summary

Following the deployment of ASWBCentral version 1.4.2.2347, users of the ASWBCentral desktop application encountered two issues pertaining to the Social Security Numbers of Colorado applicants.

Issue 1:

For applications which had the Social Security Number populated prior to the deployment, staff were seeing the encrypted value stored in the database instead of the masked social security number (****-**-####).

Issue 2:

For applications which had the Social Security Number populated after the deployment took place, staff would receive an error message stating :Unexpected error during the decryption of “########”: Invalid length for a Base-64 char array or string. Where the ######### was the applicants Social Security number

Issue Raised by:

Keeley Cook

Issue Resolved by:

Robert G. Adach

Root Cause

After review the issues reported it was determined that two configuration statements for the Social Security questions asked in each of the Colorado application processes were not reset when we deployed the newest version of the ASWBCentral. As a result, the system was unaware that data stored in this field should be de-encrypted when viewed (Issue 1) and encrypted when saved (Issue 2).

Use the Workflow Toolbox, the Development team added the configuration items to the system, which immediately addressed Issue 1.

Manual encryption of 2 social security numbers (for applications 1331,1332) had to be done by Development team.


Mitigation Actions and Next Steps

Item

Description

Due Date

Completed On

Owner

Item

Description

Due Date

Completed On

Owner

Manual review of all configuration items when altered during deployments (Mitigation Step)

When configuration items are altered during testing and must be transferred to production, the Development team will manually review these changes to validate that they were completed successfully.

On-Going

 

Development team

Review configuration of all Workflows currently in production (Mitigation Step)

Conduct a manual review of all configuration items and questions currently in production to ensure that all items are present and accurately set

ASAP

5/8/2019 13:14

Robert Adach

 


Event Impact and Timings

Usergroup(s) Affected:

  • ASWB Staff (both issue 1 and 2)

  • Colorado Applicants (issue 1)

Tickets relating to event

  • LMR-2004

Timings (in ET)

Actual Start

5/6/2019 21:00

 

First Notification

5/7/2019 15:53

 

Event Restoration

5/8/2019 11:52

 

Event Resolution

5/8/2019 11:58

 

  • Actual Start: earliest possible impact to users

  • First Notification: first time the Development Team was notified of the event

  • Event Restoration: when a workaround was put in place to address one or more issues of the event

  • Event Resolution: when all corrective actions were taken to permanently resolve the issue